What’s Vulnerable › Vulnerabilities
CVE-2023-53193: drm/amdgpu: fix amdgpu_irq_put call trace in gmc_v10_0_hw_fini
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: fix amdgpu_irq_put call trace in gmc_v10_0_hw_fini The gmc.ecc_irq is enabled by firmware per IFWI setting, and the host driver is not privileged to enable/disable the interrupt. So, it is meaningless to use the amdgpu_irq_put function in gmc_v10_0_hw_fini, which also leads to the call trace. [ 82.340264] Call Trace: [ 82.340265] <TASK> [ 82.340269] gmc_v10_0_hw_fini+0x83/0xa0 [amdgpu] [ 82.340447] gmc_v10_0_suspend+0xe/0x20 [amdgpu] [ 82.340623] amdgpu_device_ip_suspend_phase2+0x127/0x1c0 [amdgpu] [ 82.340789] amdgpu_device_ip_suspend+0x3d/0x80 [amdgpu] [ 82.340955] amdgpu_device_pre_asic_reset+0xdd/0x2b0 [amdgpu] [ 82.341122] amdgpu_device_gpu_recover.cold+0x4dd/0xbb2 [amdgpu] [ 82.341359] amdgpu_debugfs_reset_work+0x4c/0x70 [amdgpu] [ 82.341529] process_one_work+0x21d/0x3f0 [ 82.341535] worker_thread+0x1fa/0x3c0 [ 82.341538] ? process_one_work+0x3f0/0x3f0 [ 82.341540] kthread+0xff/0x130 [ 82.341544] ? kthread_complete_and_exit+0x20/0x20 [ 82.341547] ret_from_fork+0x22/0x30
Affected products
- Linux kernel: from 6.1.26 before 6.1.29; from 6.2.13 before 6.2.16; from 6.3.1 before 6.3.3; 6.3 — fixed in 6.1.29, 6.2.16, 6.3.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1.29, 6.2.16, 6.3.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08c677cb0b436a96a836792bb35a8ec5de4999c2
- https://git.kernel.org/stable/c/23febab57e345c0e66f8574c1018707e7eb6ea94
- https://git.kernel.org/stable/c/59e2439111ac2bd24ea0cecf5825cf06684b2c6c
- https://git.kernel.org/stable/c/a7e65a1ea871e99115add88ecbcfdbacc2415f07
Get alerted when CVE-2023-53193 or the next vulnerability affects your stack