What’s Vulnerable › Vulnerabilities
CVE-2023-53195: mlxsw: minimal: fix potential memory leak in mlxsw_m_linecards_init
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: mlxsw: minimal: fix potential memory leak in mlxsw_m_linecards_init The line cards array is not freed in the error path of mlxsw_m_linecards_init(), which can lead to a memory leak. Fix by freeing the array in the error path, thereby making the error path identical to mlxsw_m_linecards_fini().
Affected products
- Linux kernel: from 6.1 before 6.1.39; from 6.2 before 6.4.4 — fixed in 6.1.39, 6.4.4
How to fix
Upgrade to a fixed version: Linux kernel 6.1.39, 6.4.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08fc75735fda3be97194bfbf3c899c87abb3d0fe
- https://git.kernel.org/stable/c/cd716022c968bc6748f23708b986f845b45791b7
- https://git.kernel.org/stable/c/d4f5b1dd816dccd4ee6bb60b2a81a3d4373636a9
Get alerted when CVE-2023-53195 or the next vulnerability affects your stack