What’s Vulnerable › Vulnerabilities
CVE-2023-53219: media: netup_unidvb: fix use-after-free at del_timer()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: media: netup_unidvb: fix use-after-free at del_timer() When Universal DVB card is detaching, netup_unidvb_dma_fini() uses del_timer() to stop dma->timeout timer. But when timer handler netup_unidvb_dma_timeout() is running, del_timer() could not stop it. As a result, the use-after-free bug could happen. The process is shown below: (cleanup routine) | (timer routine) | mod_timer(&dev->tx_sim_timer, ..) netup_unidvb_finidev() | (wait a time) netup_unidvb_dma_fini() | netup_unidvb_dma_timeout() del_timer(&dma->timeout); | | ndev->pci_dev->dev //USE Fix by changing del_timer() to del_timer_sync().
Affected products
- Linux kernel: from 4.3 before 4.14.316; from 4.15 before 4.19.284; from 4.20 before 5.4.244; from 5.5 before 5.10.181; from 5.11 before 5.15.113; from 5.16 before 6.1.30 — fixed in 4.14.316, 4.19.284, 5.10.181, 5.15.113, 5.4.244, 6.1.30
How to fix
Upgrade to a fixed version: Linux kernel 4.14.316, 4.19.284, 5.10.181, 5.15.113. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/051af3f0b7d1cd8ab7f3e2523ad8ae1af44caba3
- https://git.kernel.org/stable/c/07821524f67bf920342bc84ae8b3dea2a315a89e
- https://git.kernel.org/stable/c/0f5bb36bf9b39a2a96e730bf4455095b50713f63
- https://git.kernel.org/stable/c/1550bcf2983ae1220cc8ab899a39a423fa7cb523
- https://git.kernel.org/stable/c/90229e9ee957d4514425e4a4d82c50ab5d57ac4d
- https://git.kernel.org/stable/c/c8f9c05e1ebcc9c7bc211cc8b74d8fb86a8756fc
- https://git.kernel.org/stable/c/dd5c77814f290b353917df329f36de1472d47154
- https://git.kernel.org/stable/c/f9982db735a8495eee14267cf193c806b957e942
Get alerted when CVE-2023-53219 or the next vulnerability affects your stack