What’s Vulnerable › Vulnerabilities
CVE-2023-5330: Denial of Service via Opengraph Data Cache
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Mattermost fails to enforce a limit for the size of the cache entry for OpenGraph data allowing an attacker to send a specially crafted request to the /api/v4/opengraph filling the cache and turning the server unavailable.
Affected products
- Mattermost: before 7.8.11; from 8.0.0 before 8.0.3; from 8.1.0 before 8.1.2 — fixed in 7.8.11, 8.0.3, 8.1.2
How to fix
Upgrade to a fixed version: Mattermost 7.8.11, 8.0.3, 8.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5330 or the next vulnerability affects your stack