What’s Vulnerable › Vulnerabilities
CVE-2023-53313: md/raid10: fix wrong setting of max_corr_read_errors
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: md/raid10: fix wrong setting of max_corr_read_errors There is no input check when echo md/max_read_errors and overflow might occur. Add check of input number.
Affected products
- Linux kernel: from 2.6.33 before 4.14.322; from 4.15 before 4.19.291; from 4.20 before 5.4.251; from 5.5 before 5.10.188; from 5.11 before 5.15.121; from 5.16 before 6.1.39 — fixed in 4.14.322, 4.19.291, 5.10.188, 5.15.121, 5.4.251, 6.1.39
How to fix
Upgrade to a fixed version: Linux kernel 4.14.322, 4.19.291, 5.10.188, 5.15.121. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/025fde32fb957a5c271711bc66841f817ff5f299
- https://git.kernel.org/stable/c/05d10428e8dffed0bac2502f34151729fc189cd3
- https://git.kernel.org/stable/c/31c805a44b7569ca1017a4714385182d98bba212
- https://git.kernel.org/stable/c/3c76920e547d4b931bed758bad83fd658dd88b4e
- https://git.kernel.org/stable/c/74050a3fdd4aecfd2cbf74d3c145812ab2744375
- https://git.kernel.org/stable/c/aef6e98eb772594edd4399625e4e1bbe45971fa1
- https://git.kernel.org/stable/c/b1d8f38310bce3282374983b229d94edbaf1e570
- https://git.kernel.org/stable/c/e83cb411aa1c6c9617db9329897f4506ba9e9b9d
- https://git.kernel.org/stable/c/f8b20a405428803bd9881881d8242c9d72c6b2b2
Get alerted when CVE-2023-53313 or the next vulnerability affects your stack