What’s Vulnerable › Vulnerabilities
CVE-2023-5332: Dependency on Vulnerable Third-Party Component in GitLab
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-04 · updated 2026-06-17
- Weakness: CWE-1395
Description
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
Affected products
- GitLab: from 9.5.0 before 16.2.8; from 16.3.0 before 16.3.5; 16.4.0 — fixed in 16.2.8, 16.3.5
- HashiCorp Consul: before 0.9.4; from 1.0.0 before 1.0.8; from 1.2.0 before 1.2.4; 1.1.0 — fixed in 0.9.4, 1.0.8, 1.2.4
How to fix
Upgrade to a fixed version: GitLab 16.2.8, 16.3.5; HashiCorp Consul 0.9.4, 1.0.8, 1.2.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/omnibus-gitlab/-/issues/8171
- https://www.hashicorp.com/blog/protecting-consul-from-rce-risk-in-specific-configurations
- https://gitlab.com/gitlab-org/omnibus-gitlab/-/issues/8171
- https://www.hashicorp.com/blog/protecting-consul-from-rce-risk-in-specific-configurations
Get alerted when CVE-2023-5332 or the next vulnerability affects your stack