What’s Vulnerable › Vulnerabilities
CVE-2023-5333: Denial of Service via multiple identical User IDs in /api/v4/users/ids
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Mattermost fails to deduplicate input IDs allowing a simple user to cause the application to consume excessive resources and possibly crash by sending a specially crafted request to /api/v4/users/ids with multiple identical IDs.
Affected products
- Mattermost: before 7.8.11; from 8.0.0 before 8.0.3; from 8.1.0 before 8.1.2 — fixed in 7.8.11, 8.0.3, 8.1.2
How to fix
Upgrade to a fixed version: Mattermost 7.8.11, 8.0.3, 8.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5333 or the next vulnerability affects your stack