What’s Vulnerable › Vulnerabilities
CVE-2023-53372: sctp: fix a potential overflow in sctp_ifwdtsn_skip
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-18 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: sctp: fix a potential overflow in sctp_ifwdtsn_skip Currently, when traversing ifwdtsn skips with _sctp_walk_ifwdtsn, it only checks the pos against the end of the chunk. However, the data left for the last pos may be < sizeof(struct sctp_ifwdtsn_skip), and dereference it as struct sctp_ifwdtsn_skip may cause coverflow. This patch fixes it by checking the pos against "the end of the chunk - sizeof(struct sctp_ifwdtsn_skip)" in sctp_ifwdtsn_skip, similar to sctp_fwdtsn_skip.
Affected products
- Linux kernel: from 4.16 before 4.19.281; from 4.20 before 5.4.241; from 5.5 before 5.10.178; from 5.11 before 5.15.108; from 5.16 before 6.1.25; from 6.2 before 6.2.12 — fixed in 4.19.281, 5.10.178, 5.15.108, 5.4.241, 6.1.25, 6.2.12
How to fix
Upgrade to a fixed version: Linux kernel 4.19.281, 5.10.178, 5.15.108, 5.4.241. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/32832a2caf82663870126c5186cf8f86c8b2a649
- https://git.kernel.org/stable/c/4fbd094d4131a10d06a45d64158567052a35b3f4
- https://git.kernel.org/stable/c/5c9367ac5a22d71841bcd00130f9146c9b227d57
- https://git.kernel.org/stable/c/6109f5b13ce3e3e537db6f18976ec0e9118d1c6f
- https://git.kernel.org/stable/c/79b28f42214a3d0d6a8c514db3602260bd5d6cb5
- https://git.kernel.org/stable/c/ad831a7079c99c01e801764b53bc9997c2e9c0f7
- https://git.kernel.org/stable/c/ad988e9b5ff04607e624a459209e8c2d0c15fc73
Get alerted when CVE-2023-53372 or the next vulnerability affects your stack