What’s Vulnerable › Vulnerabilities
CVE-2023-5340: Five Star Restaurant Menu and Food Ordering < 2.4.11 - Unauthenticated PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-74
Description
The Five Star Restaurant Menu and Food Ordering WordPress plugin before 2.4.11 unserializes user input via an AJAX action available to unauthenticated users, allowing them to perform PHP Object Injection when a suitable gadget is present on the blog.
Affected products
- Five Star Restaurant Menu and Food Ordering: before 2.4.11 — fixed in 2.4.11
How to fix
Upgrade to a fixed version: Five Star Restaurant Menu and Food Ordering 2.4.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/91a5847a-62e7-4b98-a554-5eecb6a06e5b
- https://wpscan.com/vulnerability/91a5847a-62e7-4b98-a554-5eecb6a06e5b
Get alerted when CVE-2023-5340 or the next vulnerability affects your stack