What’s Vulnerable › Vulnerabilities
CVE-2023-53449: s390/dasd: Fix potential memleak in dasd_eckd_init()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: s390/dasd: Fix potential memleak in dasd_eckd_init() `dasd_reserve_req` is allocated before `dasd_vol_info_req`, and it also needs to be freed before the error returns, just like the other cases in this function.
Affected products
- Linux kernel: from 5.3 before 5.4.235; from 5.5 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16; from 6.2 before 6.2.3 — fixed in 5.10.173, 5.15.99, 5.4.235, 6.1.16, 6.2.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.173, 5.15.99, 5.4.235, 6.1.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/460e9bed82e49db1b823dcb4e421783854d86c40
- https://git.kernel.org/stable/c/544a552be0869231799784279d52704c4d314d33
- https://git.kernel.org/stable/c/a50e28d433acf22258f9f34831057387f04ef074
- https://git.kernel.org/stable/c/aede5230d154b6b237985ec9df7ebbd1dce96810
- https://git.kernel.org/stable/c/ee986d80acdef710a886be404308188ea11000c8
- https://git.kernel.org/stable/c/ef3a7ffc0a6f833578bc8d1dcb79d0633c7e4ec3
Get alerted when CVE-2023-53449 or the next vulnerability affects your stack