What’s Vulnerable › Vulnerabilities
CVE-2023-53450: ext4: remove a BUG_ON in ext4_mb_release_group_pa()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: ext4: remove a BUG_ON in ext4_mb_release_group_pa() If a malicious fuzzer overwrites the ext4 superblock while it is mounted such that the s_first_data_block is set to a very large number, the calculation of the block group can underflow, and trigger a BUG_ON check. Change this to be an ext4_warning so that we don't crash the kernel.
Affected products
- Linux kernel: from 2.6.25 before 4.14.315; from 4.15 before 4.19.283; from 4.20 before 5.4.243; from 5.5 before 5.10.180; from 5.11 before 5.15.112; from 5.16 before 6.1.29 — fixed in 4.14.315, 4.19.283, 5.10.180, 5.15.112, 5.4.243, 6.1.29
How to fix
Upgrade to a fixed version: Linux kernel 4.14.315, 4.19.283, 5.10.180, 5.15.112. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/185062a21976fbc38f2efd296951b02c4500cf65
- https://git.kernel.org/stable/c/463808f237cf73e98a1a45ff7460c2406a150a0b
- https://git.kernel.org/stable/c/53c14e7cc2257191ba15425c15638fc4f8abb92b
- https://git.kernel.org/stable/c/978e5e9111af18741449b81fefd531a622dd969a
- https://git.kernel.org/stable/c/b0fc279de4bf17e1710bb7e83906538ff8f11111
- https://git.kernel.org/stable/c/bf2a16eb4e6d06124bd8436d4546f61539a65f29
- https://git.kernel.org/stable/c/d5bf8f7fb3ee3d99d1303ceb54599ea0599a4a5b
- https://git.kernel.org/stable/c/d87a4e4094c9879fc8acdff8ce59fdffa979c8e0
- https://git.kernel.org/stable/c/ef16d8a1798db1a1604ac44ca1bd73ec6bebf483
Get alerted when CVE-2023-53450 or the next vulnerability affects your stack