What’s Vulnerable › Vulnerabilities
CVE-2023-53456: scsi: qla4xxx: Add length check when parsing nlattrs
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qla4xxx: Add length check when parsing nlattrs There are three places that qla4xxx parses nlattrs: - qla4xxx_set_chap_entry() - qla4xxx_iface_set_param() - qla4xxx_sysfs_ddb_set_param() and each of them directly converts the nlattr to specific pointer of structure without length checking. This could be dangerous as those attributes are not validated and a malformed nlattr (e.g., length 0) could result in an OOB read that leaks heap dirty data. Add the nla_len check before accessing the nlattr data and return EINVAL if the length check fails.
Affected products
- Linux kernel: from 3.2 before 4.14.326; from 4.15 before 4.19.295; from 4.20 before 5.4.257; from 5.5 before 5.10.195; from 5.11 before 5.15.132; from 5.16 before 6.1.53 — fixed in 4.14.326, 4.19.295, 5.10.195, 5.15.132, 5.4.257, 6.1.53
How to fix
Upgrade to a fixed version: Linux kernel 4.14.326, 4.19.295, 5.10.195, 5.15.132. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/25feffb3fbd51ae81d92c65cebc0e932663828b3
- https://git.kernel.org/stable/c/47cd3770e31df942e2bb925a9a855c79ed0662eb
- https://git.kernel.org/stable/c/47f3be62eab50b8cd7e1ae5fc2c4dae687497c34
- https://git.kernel.org/stable/c/4ed21975311247bb84e82298eeb359ec0a0fa84d
- https://git.kernel.org/stable/c/5925e224cc6edfef57b20447f18323208461309b
- https://git.kernel.org/stable/c/6d65079c69dc1feb817ed71f5bd15e83a7d6832d
- https://git.kernel.org/stable/c/b018c0440b871d8b001c996e95fa4538bd292de6
- https://git.kernel.org/stable/c/cfa6a1a79ed6d336fac7a5d87eb5471e4401829f
- https://git.kernel.org/stable/c/f61fc650c47849637fa1771a31a11674c824138a
Get alerted when CVE-2023-53456 or the next vulnerability affects your stack