What’s Vulnerable › Vulnerabilities
CVE-2023-53482: iommu: Fix error unwind in iommu_group_alloc()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: iommu: Fix error unwind in iommu_group_alloc() If either iommu_group_grate_file() fails then the iommu_group is leaked. Destroy it on these error paths. Found by kselftest/iommu/iommufd_fail_nth
Affected products
- Linux kernel: from 4.11 before 5.15.99; from 5.16 before 6.1.16; from 6.2 before 6.2.3 — fixed in 5.15.99, 6.1.16, 6.2.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.99, 6.1.16, 6.2.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4c23124b45ee0aa895ed8d5d08871ae6b15ee336
- https://git.kernel.org/stable/c/4daa861174d56023c2068ddb03de0752f07fa199
- https://git.kernel.org/stable/c/8602fa38a63fc689eca29c8c586fac2d8a1f8739
- https://git.kernel.org/stable/c/f119ef452e2d82d912797273cb790a86f1125b3e
Get alerted when CVE-2023-53482 or the next vulnerability affects your stack