What’s Vulnerable › Vulnerabilities
CVE-2023-53493: accel/qaic: tighten bounds checking in decode_message()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: accel/qaic: tighten bounds checking in decode_message() Copy the bounds checking from encode_message() to decode_message(). This patch addresses the following concerns. Ensure that there is enough space for at least one header so that we don't have a negative size later. if (msg_hdr_len < sizeof(*trans_hdr)) Ensure that we have enough space to read the next header from the msg->data. if (msg_len > msg_hdr_len - sizeof(*trans_hdr)) return -EINVAL; Check that the trans_hdr->len is not below the minimum size: if (hdr_len < sizeof(*trans_hdr)) This minimum check ensures that we don't corrupt memory in decode_passthrough() when we do. memcpy(out_trans->data, in_trans->data, len - sizeof(in_trans->hdr)); And finally, use size_add() to prevent an integer overflow: if (size_add(msg_len, hdr_len) > msg_hdr_len)
Affected products
- Linux kernel: from 6.4 before 6.4.7; 6.5-rc1, 6.5-rc2 — fixed in 6.4.7
How to fix
Upgrade to a fixed version: Linux kernel 6.4.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/51b56382ed2a2b03347372272362b3baa623ed1e
- https://git.kernel.org/stable/c/57d14cb3bae4619ce2fb5235cb318c3d5d8f53fd
Get alerted when CVE-2023-53493 or the next vulnerability affects your stack