What’s Vulnerable › Vulnerabilities
CVE-2023-53494: crypto: xts - Handle EBUSY correctly
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: xts - Handle EBUSY correctly As it is xts only handles the special return value of EINPROGRESS, which means that in all other cases it will free data related to the request. However, as the caller of xts may specify MAY_BACKLOG, we also need to expect EBUSY and treat it in the same way. Otherwise backlogged requests will trigger a use-after-free.
Affected products
- Linux kernel: from 5.4 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16; from 6.2 before 6.2.3 — fixed in 5.10.173, 5.15.99, 6.1.16, 6.2.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.173, 5.15.99, 6.1.16, 6.2.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/51c082514c2dedf2711c99d93c196cc4eedceb40
- https://git.kernel.org/stable/c/57c3e1d63b63dc0841d41df729297cd7c1c35808
- https://git.kernel.org/stable/c/912eb10b65646ffd222256c78a1c566a3dac177d
- https://git.kernel.org/stable/c/92a07ba4f0af2cccdc2aa5ee32679c9c9714db90
- https://git.kernel.org/stable/c/d5870848879291700fe6c5257dcb48aadd10425c
Get alerted when CVE-2023-53494 or the next vulnerability affects your stack