What’s Vulnerable › Vulnerabilities
CVE-2023-53506: udf: Do not bother merging very long extents
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: udf: Do not bother merging very long extents When merging very long extents we try to push as much length as possible to the first extent. However this is unnecessarily complicated and not really worth the trouble. Furthermore there was a bug in the logic resulting in corrupting extents in the file as syzbot reproducer shows. So just don't bother with the merging of extents that are too long together.
Affected products
- Linux kernel: from 2.6.12.1 before 4.14.308; from 4.15 before 4.19.276; from 4.20 before 5.4.235; from 5.5 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16 — fixed in 4.14.308, 4.19.276, 5.10.173, 5.15.99, 5.4.235, 6.1.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.308, 4.19.276, 5.10.173, 5.15.99. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3d20e3b768aff32112bdce8d3219d923ae75f9f1
- https://git.kernel.org/stable/c/53cafe1d6d8ef9f93318e5bfccc0d24f27d41ced
- https://git.kernel.org/stable/c/5d029799d381a9ee06209a222cae75f04c5d5304
- https://git.kernel.org/stable/c/7a965da79f2d22601f329cbfce588386b0847544
- https://git.kernel.org/stable/c/965982feb333aefa9256c0fe188b5f1b958aef63
- https://git.kernel.org/stable/c/9a8d602f0723586e668bae7e65c832ceb9bcc8bc
- https://git.kernel.org/stable/c/adac9ac6d2e04ea0782b91a00ba10706002f3ec4
- https://git.kernel.org/stable/c/d52252a1de4cf96a34f722b0cd8902d8ff78eb57
Get alerted when CVE-2023-53506 or the next vulnerability affects your stack