What’s Vulnerable › Vulnerabilities
CVE-2023-53510: scsi: ufs: core: Fix handling of lrbp->cmd
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-08-04
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: ufs: core: Fix handling of lrbp->cmd ufshcd_queuecommand() may be called two times in a row for a SCSI command before it is completed. Hence make the following changes: - In the functions that submit a command, do not check the old value of lrbp->cmd nor clear lrbp->cmd in error paths. - In ufshcd_release_scsi_cmd(), do not clear lrbp->cmd. See also scsi_send_eh_cmnd(). This commit prevents that the following appears if a command times out: WARNING: at drivers/ufs/core/ufshcd.c:2965 ufshcd_queuecommand+0x6f8/0x9a8 Call trace: ufshcd_queuecommand+0x6f8/0x9a8 scsi_send_eh_cmnd+0x2c0/0x960 scsi_eh_test_devices+0x100/0x314 scsi_eh_ready_devs+0xd90/0x114c scsi_error_handler+0x2b4/0xb70 kthread+0x16c/0x1e0
Affected products
- Linux kernel: from 3.12 before 6.1.167; from 6.2 before 6.3.13; from 6.4 before 6.4.4 — fixed in 6.1.167, 6.3.13, 6.4.4
How to fix
Upgrade to a fixed version: Linux kernel 6.1.167, 6.3.13, 6.4.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/49234a401e161a2f2698f4612ab792c49b3cad1b
- https://git.kernel.org/stable/c/549e91a9bbaa0ee480f59357868421a61d369770
- https://git.kernel.org/stable/c/b6d76d63c6d21d5d26c301a46853a2aee72397d5
- https://git.kernel.org/stable/c/f3ee24af62681b942bbd799ac77b90a6d7e1fdb1
Get alerted when CVE-2023-53510 or the next vulnerability affects your stack