What’s Vulnerable › Vulnerabilities
CVE-2023-53535: net: bcmgenet: Add a check for oversized packets
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: net: bcmgenet: Add a check for oversized packets Occasionnaly we may get oversized packets from the hardware which exceed the nomimal 2KiB buffer size we allocate SKBs with. Add an early check which drops the packet to avoid invoking skb_over_panic() and move on to processing the next packet.
Affected products
- Linux kernel: from 3.15 before 4.14.308; from 4.15 before 4.19.276; from 4.20 before 5.4.235; from 5.5 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16 — fixed in 4.14.308, 4.19.276, 5.10.173, 5.15.99, 5.4.235, 6.1.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.308, 4.19.276, 5.10.173, 5.15.99. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/124ca24e0de958d2e20e0aa1e2434af7b72f8887
- https://git.kernel.org/stable/c/411317d2a4a7d6049d8efeef0d32ae43f8baefce
- https://git.kernel.org/stable/c/5c0862c2c962052ed5055220a00ac1cefb92fbcd
- https://git.kernel.org/stable/c/5f56767fb5f2df875b6553e08dbec6a45431c988
- https://git.kernel.org/stable/c/7cdb07e10c1258c08f31b24898930e4ece88d163
- https://git.kernel.org/stable/c/841881320562cbeac7046b537b91cd000480cea2
- https://git.kernel.org/stable/c/87363d1ab55e497702a9506ff423c422639c8a25
- https://git.kernel.org/stable/c/c34b1c0870323649d45c5074828d7f754dea2673
Get alerted when CVE-2023-53535 or the next vulnerability affects your stack