What’s Vulnerable › Vulnerabilities
CVE-2023-53543: vdpa: Add max vqp attr to vdpa_nl_policy for nlattr length check
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-06-18
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: vdpa: Add max vqp attr to vdpa_nl_policy for nlattr length check The vdpa_nl_policy structure is used to validate the nlattr when parsing the incoming nlmsg. It will ensure the attribute being described produces a valid nlattr pointer in info->attrs before entering into each handler in vdpa_nl_ops. That is to say, the missing part in vdpa_nl_policy may lead to illegal nlattr after parsing, which could lead to OOB read just like CVE-2023-3773. This patch adds the missing nla_policy for vdpa max vqp attr to avoid such bugs.
Affected products
- Linux kernel: from 5.15.198 before 5.15.209; from 5.16 before 6.1.47; from 6.2 before 6.4.12; 6.5-rc1, 6.5-rc2, 6.5-rc3, 6.5-rc4, 6.5-rc5, 6.5-rc6 — fixed in 5.15.209, 6.1.47, 6.4.12
How to fix
Upgrade to a fixed version: Linux kernel 5.15.209, 6.1.47, 6.4.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5d6ba607d6cb5c58a4ddf33381e18c83dbb4098f
- https://git.kernel.org/stable/c/baed19c108ac8287425b93a44985bbe9a0b1af8d
- https://git.kernel.org/stable/c/ea65e8b5e6b1a34deda7564f09c90e9e80db436a
- https://git.kernel.org/stable/c/ff71709445ac033e6e250d971683110e4781c068
Get alerted when CVE-2023-53543 or the next vulnerability affects your stack