What’s Vulnerable › Vulnerabilities
CVE-2023-53553: HID: hyperv: avoid struct memcpy overrun warning
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: HID: hyperv: avoid struct memcpy overrun warning A previous patch addressed the fortified memcpy warning for most builds, but I still see this one with gcc-9: In file included from include/linux/string.h:254, from drivers/hid/hid-hyperv.c:8: In function 'fortify_memcpy_chk', inlined from 'mousevsc_on_receive' at drivers/hid/hid-hyperv.c:272:3: include/linux/fortify-string.h:583:4: error: call to '__write_overflow_field' declared with attribute warning: detected write beyond size of field (1st parameter); maybe use struct_group()? [-Werror=attribute-warning] 583 | __write_overflow_field(p_size_field, size); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ My guess is that the WARN_ON() itself is what confuses gcc, so it no longer sees that there is a correct range check. Rework the code in a way that helps readability and avoids the warning.
Affected products
- Linux kernel: from 6.2 before 6.4.5; 6.5-rc1 — fixed in 6.4.5
How to fix
Upgrade to a fixed version: Linux kernel 6.4.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5f151364b1da6bd217632fd4ee8cc24eaf66a497
- https://git.kernel.org/stable/c/a7902cc5f5b9c95997017c8e309da760fb1deb6e
Get alerted when CVE-2023-53553 or the next vulnerability affects your stack