What’s Vulnerable › Vulnerabilities
CVE-2023-53554: staging: ks7010: potential buffer overflow in ks_wlan_set_encode_ext()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: staging: ks7010: potential buffer overflow in ks_wlan_set_encode_ext() The "exc->key_len" is a u16 that comes from the user. If it's over IW_ENCODING_TOKEN_MAX (64) that could lead to memory corruption.
Affected products
- Linux kernel: from 4.12 before 4.14.322; from 4.15 before 4.19.291; from 4.20 before 5.4.253; from 5.5 before 5.10.190; from 5.11 before 5.15.124; from 5.16 before 6.1.43 — fixed in 4.14.322, 4.19.291, 5.10.190, 5.15.124, 5.4.253, 6.1.43
How to fix
Upgrade to a fixed version: Linux kernel 4.14.322, 4.19.291, 5.10.190, 5.15.124. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5373a1aa91b2298f9305794b8270cf9896be96b6
- https://git.kernel.org/stable/c/5f1c7031e044cb2fba82836d55cc235e2ad619dc
- https://git.kernel.org/stable/c/663fff29fd613e2b0d30c4138157312ba93c4939
- https://git.kernel.org/stable/c/7ae9f55a495077f838bab466411ee6f38574df9b
- https://git.kernel.org/stable/c/9496fb96ddeb740dc6b966f4a7d8dfb8b93921c6
- https://git.kernel.org/stable/c/b1b04b56745bc79286c80aa876fabfab1e08ebf1
- https://git.kernel.org/stable/c/baf420e30364ef9efe3e29a5c0e01e612aebf3fe
- https://git.kernel.org/stable/c/caac4b6c15b66feae4d83f602e1e46f124540202
Get alerted when CVE-2023-53554 or the next vulnerability affects your stack