What’s Vulnerable › Vulnerabilities

CVE-2023-5356: Incorrect Authorization in GitLab

Description

Incorrect authorization checks in GitLab CE/EE from all versions starting from 8.13 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2, allows a user to abuse slack/mattermost integrations to execute slash commands as another user.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.5.6, 16.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5356 or the next vulnerability affects your stack