What’s Vulnerable › Vulnerabilities
CVE-2023-53570: wifi: nl80211: fix integer overflow in nl80211_parse_mbssid_elems()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-08-04
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: nl80211: fix integer overflow in nl80211_parse_mbssid_elems() nl80211_parse_mbssid_elems() uses a u8 variable num_elems to count the number of MBSSID elements in the nested netlink attribute attrs, which can lead to an integer overflow if a user of the nl80211 interface specifies 256 or more elements in the corresponding attribute in userspace. The integer overflow can lead to a heap buffer overflow as num_elems determines the size of the trailing array in elems, and this array is thereafter written to for each element in attrs. Note that this vulnerability only affects devices with the wiphy->mbssid_max_interfaces member set for the wireless physical device struct in the device driver, and can only be triggered by a process with CAP_NET_ADMIN capabilities. Fix this by checking for a maximum of 255 elements in attrs.
Affected products
- Linux kernel: from 5.16 before 6.1.46; from 6.2 before 6.4.11; 6.5-rc1, 6.5-rc2, 6.5-rc3, 6.5-rc4, 6.5-rc5 — fixed in 6.1.46, 6.4.11
How to fix
Upgrade to a fixed version: Linux kernel 6.1.46, 6.4.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6311071a056272e1e761de8d0305e87cc566f734
- https://git.kernel.org/stable/c/7d09f9f255a5f78578deba5454923072bb53b16c
- https://git.kernel.org/stable/c/e642eb67b8c10dcce758d549cc81564116e0fa49
Get alerted when CVE-2023-53570 or the next vulnerability affects your stack