What’s Vulnerable › Vulnerabilities
CVE-2023-53571: drm/i915: Make intel_get_crtc_new_encoder() less oopsy
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/i915: Make intel_get_crtc_new_encoder() less oopsy The point of the WARN was to print something, not oops straight up. Currently that is precisely what happens if we can't find the connector for the crtc in the atomic state. Get the dev pointer from the atomic state instead of the potentially NULL encoder to avoid that. (cherry picked from commit 3b6692357f70498f617ea1b31a0378070a0acf1c)
Affected products
- Linux kernel: from 5.7 before 5.10.180; from 5.11 before 5.15.111; from 5.16 before 6.1.28; from 6.2 before 6.2.15; from 6.3 before 6.3.2 — fixed in 5.10.180, 5.15.111, 6.1.28, 6.2.15, 6.3.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.180, 5.15.111, 6.1.28, 6.2.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0fe6ef82e4f4764e8f556632e4cd93d78d448e99
- https://git.kernel.org/stable/c/54202488c835dab8c648acd107f0bb8eaa699894
- https://git.kernel.org/stable/c/631420b06597a33c72b6dcef78d1c2dea17f452d
- https://git.kernel.org/stable/c/780f303233c35eeb5132e3ee1cbc8f4cebe86dd2
- https://git.kernel.org/stable/c/8cd725315c559a8a4d18ac1d7fce1d6b9a667529
- https://git.kernel.org/stable/c/fd8b0abecdf66379e9d25d7448b942b5be379cb2
Get alerted when CVE-2023-53571 or the next vulnerability affects your stack