What’s Vulnerable › Vulnerabilities
CVE-2023-53579: gpio: mvebu: fix irq domain leak
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: mvebu: fix irq domain leak Uwe Kleine-König pointed out we still have one resource leak in the mvebu driver triggered on driver detach. Let's address it with a custom devm action.
Affected products
- Linux kernel: from 3.16.40 before 3.17; from 4.8.9 before 4.9; from 4.9.1 before 5.15.124; from 5.16 before 6.1.43; from 6.2 before 6.4.8; 4.9, 4.9-rc4, 4.9-rc5, 4.9-rc6, 4.9-rc7, 4.9-rc8 (+2) — fixed in 3.17, 4.9, 5.15.124, 6.1.43, 6.4.8
How to fix
Upgrade to a fixed version: Linux kernel 3.17, 4.9, 5.15.124, 6.1.43. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/44e2afbf650f3264519643fcc9e6b4d2f6e8d547
- https://git.kernel.org/stable/c/644ee70267a934be27370f9aa618b29af7290544
- https://git.kernel.org/stable/c/b19e90521286a03bc3793fd598f20277a8f99c85
- https://git.kernel.org/stable/c/d9b791d8362359d241b4e8f4b4767c681ffdb6ef
Get alerted when CVE-2023-53579 or the next vulnerability affects your stack