What’s Vulnerable › Vulnerabilities
CVE-2023-5359: W3 Total Cache <= 2.7.5 - Sensitive Credentials Stored in Plaintext
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-200
Description
The W3 Total Cache plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 2.7.5 via Google OAuth API secrets stored in plaintext in the publicly visible plugin source. This can allow unauthenticated attackers to impersonate W3 Total Cache and gain access to user account information in successful conditions. This would not impact the WordPress users site in any way.
Affected products
- boldgrid W3 Total Cache: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: boldgrid W3 Total Cache 2.7.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/w3-total-cache/trunk/PageSpeed_Api.php#L39
- https://plugins.trac.wordpress.org/changeset/3156426/w3-total-cache/tags/2.7.6/PageSpeed_Api.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d89a534-978e-4fd8-be3a-5137bdc22dc9?source=cve
Get alerted when CVE-2023-5359 or the next vulnerability affects your stack