What’s Vulnerable › Vulnerabilities
CVE-2023-53604: dm integrity: call kmem_cache_destroy() in dm_integrity_init() error path
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: dm integrity: call kmem_cache_destroy() in dm_integrity_init() error path Otherwise the journal_io_cache will leak if dm_register_target() fails.
Affected products
- Linux kernel: from 4.12 before 4.14.315; from 4.15 before 4.19.283; from 4.20 before 5.4.243; from 5.5 before 5.10.180; from 5.11 before 5.15.111; from 5.16 before 6.1.28 — fixed in 4.14.315, 4.19.283, 5.10.180, 5.15.111, 5.4.243, 6.1.28
How to fix
Upgrade to a fixed version: Linux kernel 4.14.315, 4.19.283, 5.10.180, 5.15.111. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3877b5c1509b16eeb1f275228fd91789cd88cf17
- https://git.kernel.org/stable/c/44f29e93a55b544dc961b6f8b4e93abaeaafb9ee
- https://git.kernel.org/stable/c/6b79a428c02769f2a11f8ae76bf866226d134887
- https://git.kernel.org/stable/c/6d126899b0747305c9d39a0bcf87e0df9c3f555b
- https://git.kernel.org/stable/c/a5d8c6bf58e5b2e70fbc15f3b08dfc1ba6f269ac
- https://git.kernel.org/stable/c/c8c9c50268729bf35f6c9bb1205f490db920454e
- https://git.kernel.org/stable/c/ca8b634fdf07dee3f6dfde57079c4511480b525e
- https://git.kernel.org/stable/c/e09a592fdd6c716506774bdbebb5f6c537b47767
- https://git.kernel.org/stable/c/ff4d6b5b38429a7731e5593680d2138bf74dd546
Get alerted when CVE-2023-53604 or the next vulnerability affects your stack