What’s Vulnerable › Vulnerabilities
CVE-2023-53661: bnxt: avoid overflow in bnxt_get_nvram_directory()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-10-28
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: bnxt: avoid overflow in bnxt_get_nvram_directory() The value of an arithmetic expression is subject of possible overflow due to a failure to cast operands to a larger data type before performing arithmetic. Used macro for multiplication instead operator for avoiding overflow. Found by Security Code and Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 4.4 before 5.15.113; from 5.16 before 6.1.30; from 6.2 before 6.3.4 — fixed in 5.15.113, 6.1.30, 6.3.4
How to fix
Upgrade to a fixed version: Linux kernel 5.15.113, 6.1.30, 6.3.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/17e0453a7523ad7a25bb47af941b150a6c66d7b6
- https://git.kernel.org/stable/c/7c6dddc239abe660598c49ec95ea0ed6399a4b2a
- https://git.kernel.org/stable/c/d5eaf2a6b077f32a477feb1e9e1c1f60605b460e
- https://git.kernel.org/stable/c/efb1a257513438d43f4335f09b2f684e8167cad2
Get alerted when CVE-2023-53661 or the next vulnerability affects your stack