What’s Vulnerable › Vulnerabilities
CVE-2023-53675: scsi: ses: Fix possible desc_ptr out-of-bounds accesses
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-10-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: ses: Fix possible desc_ptr out-of-bounds accesses Sanitize possible desc_ptr out-of-bounds accesses in ses_enclosure_data_process().
Affected products
- Linux kernel: from 2.6.25 before 4.14.308; from 4.15 before 4.19.276; from 4.20 before 5.4.235; from 5.5 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16 — fixed in 4.14.308, 4.19.276, 5.10.173, 5.15.99, 5.4.235, 6.1.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.308, 4.19.276, 5.10.173, 5.15.99. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/414418abc19fa4ccf730d273061a426c07a061d6
- https://git.kernel.org/stable/c/4b8cae410472653a59e15af62c57c49b8e0a1201
- https://git.kernel.org/stable/c/584892fd29a41ef424a148118a3103b16b94fb8c
- https://git.kernel.org/stable/c/72021ae61a2bc6ca73cd593e255a10ed5f5dc5e7
- https://git.kernel.org/stable/c/79ec5dd5fb07ecaea2f978c2d7a9f2f3526e4d19
- https://git.kernel.org/stable/c/801ab13d50cf3d26170ee073ea8bb4eececb76ab
- https://git.kernel.org/stable/c/c315560e3ef77c1d822249f1743e647dc9c9912a
- https://git.kernel.org/stable/c/cffe09ca0555e235a42d6fa065e463c4b3d5b657
Get alerted when CVE-2023-53675 or the next vulnerability affects your stack