What’s Vulnerable › Vulnerabilities
CVE-2023-53680: NFSD: Avoid calling OPDESC() with ops->opnum == OP_ILLEGAL
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-07 · updated 2026-10-28
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Avoid calling OPDESC() with ops->opnum == OP_ILLEGAL OPDESC() simply indexes into nfsd4_ops[] by the op's operation number, without range checking that value. It assumes callers are careful to avoid calling it with an out-of-bounds opnum value. nfsd4_decode_compound() is not so careful, and can invoke OPDESC() with opnum set to OP_ILLEGAL, which is 10044 -- well beyond the end of nfsd4_ops[].
Affected products
- Linux kernel: from 4.14 before 5.10.220; from 5.11 before 5.15.107; from 5.16 before 6.1.24; from 6.2 before 6.2.11; 6.3-rc1, 6.3-rc2, 6.3-rc3, 6.3-rc4, 6.3-rc5 — fixed in 5.10.220, 5.15.107, 6.1.24, 6.2.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.220, 5.15.107, 6.1.24, 6.2.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/50827896c365e0f6c8b55ed56d444dafd87c92c5
- https://git.kernel.org/stable/c/804d8e0a6e54427268790472781e03bc243f4ee3
- https://git.kernel.org/stable/c/a64160124d5a078be0c380b1e8a0bad2d040d3a1
- https://git.kernel.org/stable/c/f352c41fa718482979e7e6b71b4da2b718e381cc
- https://git.kernel.org/stable/c/ffcbcf087581ae68ddc0a21460f7ecd4315bdd0e
Get alerted when CVE-2023-53680 or the next vulnerability affects your stack