What’s Vulnerable › Vulnerabilities
CVE-2023-5372
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-30 · updated 2026-06-17
- Weakness: CWE-78
Description
The post-authentication command injection vulnerability in Zyxel NAS326 firmware versions through V5.21(AAZF.15)C0 and NAS542 firmware versions through V5.21(ABAG.12)C0 could allow an authenticated attacker with administrator privileges to execute some operating system (OS) commands by sending a crafted query parameter attached to the URL of an affected device’s web management interface.
Affected products
- Zyxel NAS326 firmware: before 5.21\(aazf.16\)c0 — fixed in 5.21\(aazf.16\)c0
- Zyxel NAS542 firmware: before 5.21\(abag.13\)c0 — fixed in 5.21\(abag.13\)c0
How to fix
Upgrade to a fixed version: Zyxel NAS326 firmware 5.21\(aazf.16\)c0; Zyxel NAS542 firmware 5.21\(abag.13\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-post-authentication-command-injection-vulnerability-in-nas-products-01-30-2024
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-post-authentication-command-injection-vulnerability-in-nas-products-01-30-2024
Get alerted when CVE-2023-5372 or the next vulnerability affects your stack