What’s Vulnerable › Vulnerabilities
CVE-2023-53861: ext4: correct grp validation in ext4_mb_good_group
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ext4: correct grp validation in ext4_mb_good_group Group corruption check will access memory of grp and will trigger kernel crash if grp is NULL. So do NULL check before corruption check.
Affected products
- Linux kernel: from 5.10.181 before 5.10.195; from 5.15.113 before 5.15.132; from 6.1.30 before 6.1.53; from 6.3.4 before 6.4; 6.4 — fixed in 5.10.195, 5.15.132, 6.1.53, 6.4, 6.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.195, 5.15.132, 6.1.53, 6.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/245759d987b617d183061db6ab8886ebb5cc78e9
- https://git.kernel.org/stable/c/3e24082f16825279054a2b8a5e668d65070bbf07
- https://git.kernel.org/stable/c/772ca4bc1d0d21320ef2ecc0f9e4f90ea85a035d
- https://git.kernel.org/stable/c/83a9d5f5ec7e75640b1ba0bbd77a4888df798bb4
- https://git.kernel.org/stable/c/a9ce5993a0f5c0887c8a1b4ffa3b8046fbcfdc93
- https://git.kernel.org/stable/c/e69d665987db0e37896adf78a7e718f9a0a75d3f
Get alerted when CVE-2023-53861 or the next vulnerability affects your stack