What’s Vulnerable › Vulnerabilities
CVE-2023-5421: Possible XSS execution in customer information
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-20
Description
An attacker who is logged into OTRS as an user with privileges to create and change customer user data may manipulate the CustomerID field to execute JavaScript code that runs immediatly after the data is saved.The issue onlyoccurs if the configuration for AdminCustomerUser::UseAutoComplete was changed before. This issue affects OTRS: from 7.0.X before 7.0.47, from 8.0.X before 8.0.37; ((OTRS)) Community Edition: from 6.0.X through 6.0.34.
Affected products
- OTRS AG OTRS: from 6.0.0 through 6.0.34; from 7.0.0 before 7.0.47; from 8.0.0 before 8.0.37 — fixed in 7.0.47, 8.0.37
How to fix
Upgrade to a fixed version: OTRS AG OTRS 7.0.47, 8.0.37. Check the vendor advisory for mitigations.
References
- https://otrs.com/release-notes/otrs-security-advisory-2023-09/
- https://otrs.com/release-notes/otrs-security-advisory-2023-09/
Get alerted when CVE-2023-5421 or the next vulnerability affects your stack