What’s Vulnerable › Vulnerabilities
CVE-2023-5434: Superb slideshow gallery <= 13.1 - Authenticated (Subscriber+) SQL Injection via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-89
Description
The Superb slideshow gallery plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 13.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with subscriber-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- gopiplus Superb slideshow gallery: before 13.2 — fixed in 13.2
How to fix
Upgrade to a fixed version: gopiplus Superb slideshow gallery 13.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/superb-slideshow-gallery/trunk/superb-slideshow-gallery.php?rev=2827170#L127
- https://plugins.trac.wordpress.org/changeset/2985501/superb-slideshow-gallery#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3a12945d-a67c-4a19-a4e7-f65f5f2a21bb?source=cve
- https://plugins.trac.wordpress.org/browser/superb-slideshow-gallery/trunk/superb-slideshow-gallery.php?rev=2827170#L127
- https://plugins.trac.wordpress.org/changeset/2985501/superb-slideshow-gallery#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3a12945d-a67c-4a19-a4e7-f65f5f2a21bb?source=cve
Get alerted when CVE-2023-5434 or the next vulnerability affects your stack