What’s Vulnerable › Vulnerabilities
CVE-2023-5436: Vertical marquee plugin <= 7.1 - Authenticated (Subscriber+) SQL Injection via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-89
Description
The Vertical marquee plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 7.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with subscriber-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- gopiplushotmailcom Vertical marquee plugin: before 7.2 — fixed in 7.2
How to fix
Upgrade to a fixed version: gopiplushotmailcom Vertical marquee plugin 7.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/vertical-marquee-plugin/trunk/vertical-marquee-plugin.php?rev=2827080#L170
- https://plugins.trac.wordpress.org/changeset/2985561/vertical-marquee-plugin#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cd90d9c0-0cab-4fd3-b016-106032f300f7?source=cve
- https://plugins.trac.wordpress.org/browser/vertical-marquee-plugin/trunk/vertical-marquee-plugin.php?rev=2827080#L170
- https://plugins.trac.wordpress.org/changeset/2985561/vertical-marquee-plugin#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cd90d9c0-0cab-4fd3-b016-106032f300f7?source=cve
Get alerted when CVE-2023-5436 or the next vulnerability affects your stack