What’s Vulnerable › Vulnerabilities
CVE-2023-5437: WP fade in text news <= 12.0 - Authenticated (Subscriber+) SQL Injection via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP fade in text news plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 12.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with subscriber-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- gopiplus WP fade in text news: before 12.1 — fixed in 12.1
How to fix
Upgrade to a fixed version: gopiplus WP fade in text news 12.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-fade-in-text-news/trunk/wp-fade-in-text-news.php?rev=2827202#L236
- https://plugins.trac.wordpress.org/changeset/2985398/wp-fade-in-text-news#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b4accf10-710e-4cba-8d61-04e422324f9d?source=cve
- https://plugins.trac.wordpress.org/browser/wp-fade-in-text-news/trunk/wp-fade-in-text-news.php?rev=2827202#L236
- https://plugins.trac.wordpress.org/changeset/2985398/wp-fade-in-text-news#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b4accf10-710e-4cba-8d61-04e422324f9d?source=cve
Get alerted when CVE-2023-5437 or the next vulnerability affects your stack