What’s Vulnerable › Vulnerabilities
CVE-2023-5438: wp image slideshow <= 12.0 - Authenticated (Subscriber+) SQL Injection via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-89
Description
The wp image slideshow plugin for WordPress is vulnerable to SQL Injection via the plugin's shortcode in versions up to, and including, 12.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with subscriber-level and above permissions to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- gopiplus wp image slideshow: before 12.1 — fixed in 12.1
How to fix
Upgrade to a fixed version: gopiplus wp image slideshow 12.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-image-slideshow/trunk/wp-image-slideshow.php?rev=2827205#L189
- https://plugins.trac.wordpress.org/changeset/2985394/wp-image-slideshow#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7e24383b-5b0f-4114-908b-4c2778632f73?source=cve
- https://plugins.trac.wordpress.org/browser/wp-image-slideshow/trunk/wp-image-slideshow.php?rev=2827205#L189
- https://plugins.trac.wordpress.org/changeset/2985394/wp-image-slideshow#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7e24383b-5b0f-4114-908b-4c2778632f73?source=cve
Get alerted when CVE-2023-5438 or the next vulnerability affects your stack