What’s Vulnerable › Vulnerabilities
CVE-2023-54392: PocketMine-MP before 4.22.3 Denial of Service via BlockActorDataPacket
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP versions >= 4.20.0 before 4.22.3 (and before 5.2.1 in the 5.x branch) fail to validate NBT tag types in BlockActorDataPacket. A player can crash the server by sending a packet containing sign NBT data with an incorrect tag type, triggering an unhandled UnexpectedTagTypeException that terminates the server process.
Affected products
- pmmp PocketMine-MP: from 4.20.0 before 4.22.3; from 5.0.0 before 5.2.1 — fixed in 4.22.3, 5.2.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.22.3, 5.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/0c250a2ef09627b48aa52302f6cc7e1f2afb70ea
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-7wrv-6h42-w54f
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.22.3-denial-of-service-via-blockactordatapacket
Get alerted when CVE-2023-54392 or the next vulnerability affects your stack