What’s Vulnerable › Vulnerabilities
CVE-2023-54393: PocketMine-MP before 4.20.5 Denial of Service via LoginPacket
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-08
- Weakness: CWE-20
Description
PocketMine-MP versions before 4.20.5 contain a denial of service vulnerability in LoginPacket JSON parsing due to improper validation in the JsonMapper dependency. Attackers can send malformed JSON structures in LoginPacket to crash the server.
Affected products
- pmmp PocketMine-MP: before 4.20.5; from 4.21.0 before 4.21.1 — fixed in 4.20.5, 4.21.1
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.20.5, 4.21.1. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/09668a37d66c6023685a948b7550c918620e98f2
- https://github.com/pmmp/PocketMine-MP/commit/a31902a31f5b6fdb832f57c0e3a3f16a3b41c012
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-pqp3-8rrw-g8vm
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.20.5-denial-of-service-via-loginpacket
Get alerted when CVE-2023-54393 or the next vulnerability affects your stack