What’s Vulnerable › Vulnerabilities
CVE-2023-54394: PocketMine-MP before 4.18.0-ALPHA2 Bandwidth Amplification via InventoryTransactionPacket
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-08
- Weakness: CWE-770
Description
PocketMine-MP before 4.18.0-ALPHA2 fails to rate-limit mismatch type InventoryTransactionPacket requests, allowing attackers to trigger excessive inventory synchronization. Attackers can send numerous mismatch transactions to force the server to transmit large amounts of serialized inventory data, consuming significant bandwidth without authentication.
Affected products
- pmmp PocketMine-MP: before 4.18.0-ALPHA2 — fixed in 4.18.0-ALPHA2
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 4.18.0-ALPHA2. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/ca6d51498f12427a947467da8fcad7811418e6cc
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-42qm-8v8m-m78c
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.18.0-alpha2-bandwidth-amplification-via-inventorytransactionpacket
Get alerted when CVE-2023-54394 or the next vulnerability affects your stack