What’s Vulnerable › Vulnerabilities
CVE-2023-54397: Tornado before 6.3.3 HTTP Request Smuggling via Content-Length
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-17
- Weakness: CWE-444
Description
Tornado before 6.3.3 contains an HTTP request smuggling vulnerability due to improper parsing of Content-Length headers accepting non-standard characters. Attackers can send crafted HTTP requests with these characters to bypass proxy validation and smuggle requests when deployed behind certain proxies.
Affected products
- Pypi Tornado: before 6.3.3; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+63) — fixed in 6.3.3
- tornadoweb tornado: before 6.3.3 — fixed in 6.3.3
How to fix
Upgrade to a fixed version: Pypi Tornado 6.3.3; tornadoweb tornado 6.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-qppv-j76h-2rpx
- https://www.vulncheck.com/advisories/tornado-before-6.3.3-http-request-smuggling-via-content-length
Get alerted when CVE-2023-54397 or the next vulnerability affects your stack