What’s Vulnerable › Vulnerabilities
CVE-2023-54406: Frappe before 14.59.0 Safe Execution Flag Bypass in Server Scripts
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-15
- Weakness: CWE-372
Description
Frappe before 14.59.0 and 15.x before 15.5.0 contains a sandbox flaw where the frappe.flags.in_safe_exec global flag can become False during Server Script execution when one server script triggers another. Authenticated high-privileged users can craft a Server Script that triggers other server scripts, such as by saving a document, so the remaining code runs without safe execution protections.
Affected products
- frappe: before 14.59.0; from 15.0.0 before 15.5.0 — fixed in 14.59.0, 15.5.0
How to fix
Upgrade to a fixed version: frappe 14.59.0, 15.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-v3vh-7qx4-f582
- https://www.vulncheck.com/advisories/frappe-before-14.59.0-safe-execution-flag-bypass-in-server-scripts
Get alerted when CVE-2023-54406 or the next vulnerability affects your stack