What’s Vulnerable › Vulnerabilities
CVE-2023-54408: Frappe before 14.31.0 HTML Injection via Weak Escaping
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-79
Description
Frappe before 13.52.0 and 14.x before 14.31.0 contains an HTML injection vulnerability caused by weak escaping of user-supplied content rendered in pages. Attackers can submit crafted HTML that bypasses the insufficient escaping and is rendered in the browsers of users who view it, enabling cross-site scripting.
Affected products
- frappe: before 13.52.0; from 14.0.0-beta.1 before 14.31.0 — fixed in 13.52.0, 14.31.0
How to fix
Upgrade to a fixed version: frappe 13.52.0, 14.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-4jj9-5vgc-gc4j
- https://www.vulncheck.com/advisories/frappe-before-14.31.0-html-injection-via-weak-escaping
Get alerted when CVE-2023-54408 or the next vulnerability affects your stack