What’s Vulnerable › Vulnerabilities
CVE-2023-54409: Frappe before 13.46.1 XSS via html2text Weak Sanitization
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-13
- Weakness: CWE-80
Description
Frappe before 13.46.1 and 14.x before 14.20.0 contains a cross-site scripting vulnerability because the html2text function weakly sanitizes user input. Authenticated attackers can supply crafted HTML that is insufficiently sanitized by html2text, executing scripts in the browsers of users who view the rendered content.
Affected products
- frappe: before 13.46.1; from 14.0.0-beta.1 before 14.20.0 — fixed in 13.46.1, 14.20.0
How to fix
Upgrade to a fixed version: frappe 13.46.1, 14.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-wp7j-3w22-93j6
- https://www.vulncheck.com/advisories/frappe-before-13.46.1-xss-via-html2text-weak-sanitization
Get alerted when CVE-2023-54409 or the next vulnerability affects your stack