What’s Vulnerable › Vulnerabilities
CVE-2023-54410: Frappe before 13.22.0 Improper Authorization via Document Rename
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-18
- Weakness: CWE-285
Description
Frappe before 13.22.0 contains an improper authorization vulnerability that allows authenticated users to rename documents by exploiting a missing permission check. Attackers can invoke the document rename functionality on documents they lack permission to modify, altering records without proper authorization.
Affected products
- frappe: before 13.22.0 — fixed in 13.22.0
How to fix
Upgrade to a fixed version: frappe 13.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-whww-ggp5-r2xq
- https://www.vulncheck.com/advisories/frappe-before-13.22.0-improper-authorization-via-document-rename
Get alerted when CVE-2023-54410 or the next vulnerability affects your stack