What’s Vulnerable › Vulnerabilities
CVE-2023-5450: BIG-IP Edge Client for macOS vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-10 · updated 2026-06-17
- Weakness: CWE-345
Description
An insufficient verification of data vulnerability exists in BIG-IP Edge Client Installer on macOS that may allow an attacker elevation of privileges during the installation process. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 BIG-IP APM: from 7.2.3 before 7.2.4.5; from 13.1.0 through 13.1.5; from 14.1.0 through 14.1.5; from 15.1.0 before 15.1.10; from 16.1.0 before 16.1.4; 17.1.0 — fixed in 15.1.10, 16.1.4, 7.2.4.5
How to fix
Upgrade to a fixed version: F5 BIG-IP APM 15.1.10, 16.1.4, 7.2.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5450 or the next vulnerability affects your stack