What’s Vulnerable › Vulnerabilities
CVE-2023-5452: Cross-site Scripting (XSS) - Stored in snipe/snipe-it
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository snipe/snipe-it prior to v6.2.2.
Affected products
- grokability snipe-it: before 6.2.2 — fixed in 6.2.2
How to fix
Upgrade to a fixed version: grokability snipe-it 6.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/eea2eabaeef16fc8f3a1d61b19c06e9fc8ed942a
- https://huntr.dev/bounties/d6ed5ac1-2ad6-45fd-9492-979820bf60c8
- https://github.com/snipe/snipe-it/commit/eea2eabaeef16fc8f3a1d61b19c06e9fc8ed942a
- https://huntr.dev/bounties/d6ed5ac1-2ad6-45fd-9492-979820bf60c8
Get alerted when CVE-2023-5452 or the next vulnerability affects your stack