What’s Vulnerable › Vulnerabilities

CVE-2023-5512: Improper Control of Generation of Code ('Code Injection') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.3 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. File integrity may be compromised when specific HTML encoding is used for file names leading for incorrect representation in the UI.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5512 or the next vulnerability affects your stack