What’s Vulnerable › Vulnerabilities
CVE-2023-5541: Moodle: xss risk when using csv grade import method
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The CSV grade import method contained an XSS risk for users importing the spreadsheet, if it contained unsafe content.
Affected products
- Moodle: from 3.9.0 before 3.9.24; from 3.11.0 before 3.11.17; from 4.0.0 before 4.0.11; from 4.1.0 before 4.1.6; from 4.2.0 before 4.2.3 — fixed in 3.11.17, 3.9.24, 4.0.11, 4.1.6, 4.2.3
How to fix
Upgrade to a fixed version: Moodle 3.11.17, 3.9.24, 4.0.11, 4.1.6. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-79426
- https://bugzilla.redhat.com/show_bug.cgi?id=2243437
- https://moodle.org/mod/forum/discuss.php?d=451582
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-79426
- https://bugzilla.redhat.com/show_bug.cgi?id=2243437
- https://moodle.org/mod/forum/discuss.php?d=451582
Get alerted when CVE-2023-5541 or the next vulnerability affects your stack