What’s Vulnerable › Vulnerabilities
CVE-2023-5550: Moodle: rce due to lfi risk in some misconfigured shared hosting environments
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-09 · updated 2026-06-17
- Weakness: CWE-94
Description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file include to achieve remote code execution.
Affected products
- Fedoraproject Extra Packages For Enterprise Linux: 7.0
- Fedoraproject Fedora: 38
- Moodle: before 3.9.24; from 3.11.0 before 3.11.17; from 4.0.0 before 4.0.11; from 4.1.0 before 4.1.6; from 4.2.0 before 4.2.3 — fixed in 3.11.17, 3.9.24, 4.0.11, 4.1.6, 4.2.3
How to fix
Upgrade to a fixed version: Moodle 3.11.17, 3.9.24, 4.0.11, 4.1.6. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72249
- https://bugzilla.redhat.com/show_bug.cgi?id=2243452
- https://moodle.org/mod/forum/discuss.php?d=451591
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72249
- https://bugzilla.redhat.com/show_bug.cgi?id=2243452
- https://moodle.org/mod/forum/discuss.php?d=451591
Get alerted when CVE-2023-5550 or the next vulnerability affects your stack